Re: update Japanese LM and AU

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: update Japanese LM and AU

John Mandereau
Hello Yoshiki,
Le mercredi 19 août 2009 à 20:01 +0900, Yoshiki Sawada a écrit :
> I have updated Japanese LM and AU.
> I have made a patch for it and uploaded the patch

Thanks, I applied, tested and pushed it, except
Documentation/ja/i18n/ja.


> 5. Add "Documentation/ja/i18n/ja" (to fix characters in navigation
> tables).

This file (attached below) has not its place in LilyPond sources, it
should be integrated in texi2html sources.  However, I changed
translations.pl in texi2html sources to integate your changes, and the
attached patch reveals that you remove a lot of translations; I don't
understand why you do this.  I attached a screen print of the Japanese
documentation in Firefox, what is incorrect on this page?

Best,
John

ja (13K) Download Attachment
Lily-doc-Japanese.jpg (59K) Download Attachment
translations.pl.diff (17K) Download Attachment
signature.asc (204 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: update Japanese LM and AU

Yoshiki Sawada
Hello John,

Le mercredi 19 août 2009 à 20:01 +0900, Yoshiki Sawada a écrit :
> I have updated Japanese LM and AU.
> I have made a patch for it and uploaded the patch

Thanks, I applied, tested and pushed it, except
Documentation/ja/i18n/ja.

Thank you very much, John.
Japanese LilyPond users will be pleased.


> 5. Add "Documentation/ja/i18n/ja" (to fix characters in navigation
> tables).

This file (attached below) has not its place in LilyPond sources, it
should be integrated in texi2html sources.

Yes, it is the best.
 
However, I changed
translations.pl in texi2html sources to integate your changes, and the
attached patch reveals that you remove a lot of translations; I don't
understand why you do this.

The documents in lilypond.org have wrong navigation tables.
(Please look at my attached image.)
I guess texi2html generates navigation tables in UTF-8
but it specifies US-ASCII for their character code.
Therefore, I reverted navigation tables to English using "i18n/ja"
and translated them by "ja.po".
Even if I can fix my texi2html, I cannot fix it for others.

 I attached a screen print of the Japanese
documentation in Firefox, what is incorrect on this page?

Your screen shot looks good. Translations work very well.
(I have a request: I want to change "冒頭" and "見出し" to
"トップ ページ" and "インデックス" respectively if I can.)

Thanks,
Sawada, Yoshiki

ScreenShot.png (29K) Download Attachment
Loading...