nodes in macros.itexi

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

nodes in macros.itexi

Federico Bruni-2
I think that the following patch should fix wrong links in the italian
Manuals page (only if browsed locally, the links to not translated
manuals end with /su.it.html).

I couldn't test it because I can't compile docs.
Please apply and let me know if it fixes the problem.

Thanks,
Federico



PS I think that the following sentences in macros.itexi are in
contradiction:

@ignore
****************************
MACRO DEFINITIONS GUIDELINES
****************************

This file should contain macro definitions which are common to all
languages, i.e. all macro definitions which do not contain text that
should be translated (namely text visible in the output).

Macro definitions which contain text that should be translated in
translations should be in macros.itexi.
@end ignore

0001-Doc-it-fix-wrong-node-translation-update.patch (3K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: nodes in macros.itexi

Francisco Vila
2011/10/31 Federico Bruni <[hidden email]>:
> I think that the following patch should fix wrong links in the italian
> Manuals page (only if browsed locally, the links to not translated manuals
> end with /su.it.html).
>
> I couldn't test it because I can't compile docs.
> Please apply and let me know if it fixes the problem.

I have applied it but have not any time right now to test it (sorry
for that). It seems there is another "@node Su" and it is in
it/web.texi , does this cause problems too?

--
Francisco Vila. Badajoz (Spain)
www.paconet.org , www.csmbadajoz.com


Reply | Threaded
Open this post in threaded view
|

Re: nodes in macros.itexi

Federico Bruni-2
Il 31/10/2011 23:56, Francisco Vila ha scritto:
> I have applied it but have not any time right now to test it (sorry
> for that). It seems there is another "@node Su" and it is in
> it/web.texi , does this cause problems too?

Oh, I missed that, thanks!
I don't know what kind of problems it can cause, but it should be fixed.

Find attached another patch.
A single patch would have been better, I guess.
Let me know if it's ok.

I'll try to figure out why I can't compile docs

0001-Web-it-fix-a-node-that-should-not-be-translated.patch (673 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: nodes in macros.itexi

Federico Bruni-2
In reply to this post by Francisco Vila
Il 31/10/2011 23:56, Francisco Vila ha scritto:
>> I couldn't test it because I can't compile docs.
>> >  Please apply and let me know if it fixes the problem.
> I have applied it but have not any time right now to test it (sorry
> for that). It seems there is another "@node Su" and it is in
> it/web.texi , does this cause problems too?

I've finally managed to compile documentation.
I had stumbled upon issue 1997. Using 'configure --disable-optimising'
I've been able to run make doc successfully.

I can confirm that links are correct now.

Cheers,
Federico


Reply | Threaded
Open this post in threaded view
|

Re: nodes in macros.itexi

Francisco Vila
In reply to this post by Federico Bruni-2
2011/11/1 Federico Bruni <[hidden email]>:

> Il 31/10/2011 23:56, Francisco Vila ha scritto:
>>
>> I have applied it but have not any time right now to test it (sorry
>> for that). It seems there is another "@node Su" and it is in
>> it/web.texi , does this cause problems too?
>
> Oh, I missed that, thanks!
> I don't know what kind of problems it can cause, but it should be fixed.
>
> Find attached another patch.
> A single patch would have been better, I guess.
> Let me know if it's ok.


Oh, it's completely OK, make as many patches as you need to do.
Applied and pushed.

--
Francisco Vila. Badajoz (Spain)
www.paconet.org , www.csmbadajoz.com